Напишите программу на паскале, которая в двумерном массиве находит самое большое значение и элементы строки и столбца, на пересечении которых он стоит, делает нулевыми. я начал решать, нашел максимальное значение в массиве, а вот дальше что-то не понял. возьмите кол-во столбцов и строк по 5. заранее. : )

dronyuk88 dronyuk88    2   25.05.2019 23:00    5

Ответы
ренатка6 ренатка6  22.06.2020 06:53
Var max_i, max_j, j, columns, rows, i : integer;
arr: array[1..10,1..10] of integer;
Begin
  rows := random(8) + 2;
  columns := random(8) + 2;
  writeln(rows, columns);
 
  for i := 1 to rows do
    for j := 1 to columns do
      arr[i, j] := random(100);

  for i := 1 to rows do begin
    writeln();
    for j := 1 to columns do
      write(arr[i, j]:3);
  end;
  writeln();
  writeln();

  max_i:=1;
  max_j:=1;

  for i := 1 to rows do
    for j := 1 to columns do
      if arr[max_i, max_j] < arr[i, j] then begin
        max_i:=i;
        max_j:=j;
      end;

  for i := 1 to rows do
    if i <> max_i then
      arr[i, max_j] := 0;

  for j := 1 to columns do
    if j <> max_j then
      arr[max_i, j] := 0;

  for i := 1 to rows do begin
    writeln();
    for j := 1 to columns do
      write(arr[i, j]:3);
  end;
  writeln();
  writeln();
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика