Напишите программу на паскале которая решает уравнение ax^2+bx+c=0 используя циклы

6aPaLlJek 6aPaLlJek    1   08.09.2019 20:50    3

Ответы
linniklera linniklera  07.10.2020 01:42
Для Одри можно и покороче ))
Только для случая одного корня печатается 2 одинаковых. Так тоже можно

Var a,b,c,d: real;
Begin
WriteLn('Решение ax^2 + bx +c = 0');
WriteLn('Введите a b с '); ReadLn (a, b, c);
if a=0 then WriteLn('Это не квадратное уравнение. Решайте его сами! ')
else
begin
d:=b*b-4*a*c;
if d<0 then Writeln('Нет действительных корней')
else WriteLn('корни: ', (-b+Sqrt(d))/(2*a),' и ', (-b-Sqrt(d))/(2*a) );
end;
ReadLn
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика