Напишите программу на Паскале, используя цикл for.

Найти сумму из n введенных чисел.​

vova423 vova423    3   06.11.2020 01:25    1

Ответы
Юля1ьагааащщн Юля1ьагааащщн  06.12.2020 01:25

program amountn;

var

 amount, n, number, i: integer;

begin

 amount := 0;

 write('Введите количество чисел: ');

 read(n);

 for i := 1 to n do

 begin

   read(number);

   amount := amount + number;

 end;

 writeln('Сумма n чисел: ', amount);

end.

Объяснение:

program amountn;  // Название программы

var

 amount, n, number, i: integer;  // Целочисленные переменные:

amount - сумма чисел;n - количество чисел;number - сами числа;i - счетчик для цикла for.

begin  // Начало программы

 amount := 0; // Переменная, хранящая сумму, = 0

 write('Введите количество чисел: ');  // Вывод сообщения в консоль

 read(n);  // Считываем количество чисел с клавиатуры

 for i := 1 to n do  // Идём с единицы до n (цикл для ввода n чисел)

 begin  // Начало цикла

   read(number);  // Считываем число с клавиатуры

   amount := amount + number;  // К переменной, хранящей сумму, прибавляем число

 end;  // Конец цикла

 writeln('Сумма n чисел: ', amount);

end. // Конец программы

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика