Напишите программу на паскале
Дано неотрицательное целое N. Найти сумму и количество цифр в
системе счисления с основанием q.
q=2

nosok666 nosok666    3   27.11.2020 06:36    9

Ответы
GGG123366699 GGG123366699  27.12.2020 06:45

var

 i, p, n, q, sum: integer;

 a : array[1..1000000] of byte;

begin

 Write('Введите число N: ');

 ReadLn(n);

 Write('Введите основание системы счисления q: ');

 ReadLn(q);

 p := n;

 while p > 0 do

   begin

     i := i + 1;

     a[i] := p mod q;

     sum := sum + a[i];

     p := p div q;

   end;

 Write(n,'(10) = ');

 for p := i downto 1 do

   Write(a[p]);

 WriteLn('(', q, ')');

 WriteLn('Сумма цифр полученного числа равна ', sum);

 WriteLn('Количество цифр полученного числа равна ', i);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика