Напишите программу на pascalabc - дано слово. переставьте его последнюю букву на место первой. подразумевается при этом, что все последующие буквы будут сдвинуты вправо на одну позицию. вводится строка, состоящая из одного слова (последовательность строчных латинских букв без пробелов) длиной не более 150 символов.

nasstya05 nasstya05    2   08.10.2019 07:10    2

Ответы
Retro2122 Retro2122  10.10.2020 03:36

var

 str:string;

 s:char;

 i:integer;

Begin

 readln(str);

 s := str[length(str)];

 str := str + '0';

 for i := length(str)-1 downto 1 do begin

   str[i+1] := str[i];

 end;

 str[1] := s;

 delete(str, length(str), 1);

 writeln(str);

End.

жду лучший ответ

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика