Напишите программу на PASCAL для решения следующей задачи. Пользователь вводит с клавиатуры координаты трех вершин прямоугольного треугольника: (x1, y1), (x2, y2), (x3, y3). Необходимо найти его периметр, считая, что длина каждой стороны рассчитывается по формуле: √(x2−x1)2+(y2−y1)2.

vovkahooligan vovkahooligan    2   17.06.2020 21:55    6

Ответы
darialitvinenko darialitvinenko  15.10.2020 14:23

var x1, x2, x3, y1, y2, y3, d1, d2, d3, P:real;

begin

readln(x1, y1);

readln(x2, y2);

readln(x3, y3);

d1:=sqrt(((x2-x1)*(x2-x1))+((y2-y1)*(y2-y1)));

d2:=sqrt(((x3-x2)*(x3-x2))+((y3-y2)*(y3-y2)));

d3:=sqrt(((x1-x3)*(x1-x3))+((y1-y3)*(y1-y3)));

P:=d1+d2+d3;

writeln('Периметр равен: ', round(P));

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика