Напишите программу на c++.Условия: Напишите программу, которая выполняет реверс массива: меняет местами первый и последний элементы, второй и предпоследний и т.д.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

missvictoriak missvictoriak    2   08.02.2021 15:05    5

Ответы
vanyadrachuk2004 vanyadrachuk2004  10.03.2021 15:07

var a:array[1..1000] of real;

i,N:integer;

k:real;

begin

write('Введите размерность массива: ');

readln(N);

write('Введите элементы массива: ');

for i:=1 to N do

read(a[i]);

writeln('Элементы массива a: ');

for i:=1 to N do

write(a[i],' ');

writeln;

for i:=1 to N div 2 do

begin

k:=a[i];

a[i]:=a[N-i+1];

a[N-i+1]:=k;

end;

for i:=1 to N do

write(a[i],' ');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика