Напишите программу на c#, которая запрашивает с клавиатуры четыре целых числа и выводит на экран таблицу, в которой для каждого из этих чисел выводится его модуль, квадратный корень и значение в четвертой степени. при выводе нецелых значений выводите два знака после запятой.

Anchoys777 Anchoys777    3   03.08.2019 11:40    4

Ответы
Nemuverus Nemuverus  07.08.2020 22:59
Yaaas, я дождался C#, надеюсь что еще нужно

Console.WriteLine("Введите первое число: ");
int a = Convert.ToInt32(Console.ReadLine()); //первое число, спс, кэп
Console.WriteLine("Введите второе число: ");
int b = Convert.ToInt32(Console.ReadLine()); // второе число
Console.WriteLine("Введите третье число: ");
int c = Convert.ToInt32(Console.ReadLine()); // третье число
Console.WriteLine("Введите четвертое число: ");
int d = Convert.ToInt32(Console.ReadLine()); // четвертое число

int [] mass = new int {a, b, c, d}; // заносим числа в массив

for (int i = 0; i < mass.Length; i++) //пробегаем по массиву
{
    int module = Math.Abs(mass[i]); // находим модуль
    int koren = Math.Sqrt(mass[i]); // находим корень
    int stepen = Math.Pow(mass[i], 4); // находим 4 степень
    Console.WriteLine( Math.Round(mass[i], 2) + " " + Math.Roubnd(module, 2) +  " " + Math.Round(koren, 2) +  " " + Math.Round(stepen, 2) + "\n"); // выводим таблицу. \n - перенос на следующую строку
}

Если что, то не проверял запускается она или нет, лень VS включать. Но по идее все так должно быть.
Если что - пиши. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика