tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу на c++, которая
Напишите программу на c++, которая вычисляет значение выражения: y=1+2^2+3^3++n^n (n вводится пользователем)
NASTUHA6
1 24.08.2019 05:30
2
Ответы
yhenik2015
05.10.2020 16:03
//MV C++ 2010
#include <iostream>
#include <cmath>
using namespace std;
long double forpow(int n)
{
double i;
long double rez=0;
for (i=1; i<=n; i++) rez+=pow(i, i);
return rez;
}
int main()
{
int a;
cin >>a;
cout<<forpow(a);
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
abarzenkov
19.04.2019 20:06
Определите значение переменной a в результате выполнения фрагмента программы, представленного на языке паскпль : а : = 7 ; b : = -2 ; if a+b 0 then a: = a*b else a:...
Martina17
19.01.2020 16:20
Составьте, , информационную модель школы в виде графа и таблицы. ...
arzushka75
20.01.2021 18:15
Подготовка сценариев выступления Название кейса Исполнитель Цель презентации Введение Основная часть Заключение Тезисы Полина-айтишница Полина трудится в крупной ИТ-компании....
Elizaveta544435
20.01.2021 18:16
В каком году был изобретён 1 робот сапёр...
Sergeyii
20.01.2021 18:17
Выполни исследовательский проект по предложенным темам...
EgueneOKSDFSOFK
28.09.2019 05:10
Є24 монети однакової вартості серед яких є фальшива відомо що вона легша від інших. як визначити фальшиву монету 3 зважуваннями терезами...
laskovetsigor2
28.09.2019 03:05
Скопируйте дерево каталогов , включая пустые, расположенные в месте , путь к которому задайте самостоятельно , в точку назначения на другом локальном диске. сделайте...
dzyskristina503
14.08.2021 18:47
Задание 4. Определите, к какому виду прикладных программ относятся перечисленные ниже программные продукты. 1) Текстовые редакторы 2) Графические редакторы 3) Электронные...
tainyanonimusp08coh
01.02.2022 08:08
in care sir de mai jos sunt numai substantive care au forme de singular şi plural? a) zăpadă, copil, foarfece, frică; b) soare, portret, erou, urzică; c) semănătoare,...
ghtrwsd18
01.02.2022 08:08
Какие органы учавствуют в питании?И почему?...
Популярные вопросы
Ккакому уровню организации живого можно отнести хромосомные мутации?...
3
Укожному реченні визначити синтаксичну роль інфінітива....
3
Какое число надо написать вместо вопросительного знака?...
2
1. в каком предложении употреблено союзное слово? а) он медленно...
1
2а³b³c; -3abc³возвести в 4 степень ...
3
Молекулярная формула фенола: 1) с7h8 2) c6h12o 3) c7h8o 4) c7h8nh2...
2
Закон движения материальной точки имеет вид r=3tr+(3+2rt2)j. найти...
1
Напишите сочинение-рассуждение на тему недоросль- пьеса жизни !...
1
Отрезок 60 см разделён на четыре неравных отрезка. расстояние между...
3
Знайдіть дві останні цифри числа 1999 у 2000 степені ?...
1
#include <iostream>
#include <cmath>
using namespace std;
long double forpow(int n)
{
double i;
long double rez=0;
for (i=1; i<=n; i++) rez+=pow(i, i);
return rez;
}
int main()
{
int a;
cin >>a;
cout<<forpow(a);
return 0;
}