Напишите программу на C ++, чтобы проверить, является ли число простым или нет.​

hellllo hellllo    3   14.03.2021 11:16    1

Ответы
Медуха Медуха  13.04.2021 11:17

# include <iostream>

# include <stdio.h>

 

void main(void)

{      float k; int l,n;

       l=0;

std::cout<<"ww chislo n=";

std::cin>>n;

 

 

 

for(int i=2;i<n-1;i++){

k=n/i;

if (k==int(k))

l=l+1;

else

l=l;

}

if (l>=1)

std::cout<<"chislo ne proste";

else

std::cout<<"chislo n="<<n<<" proste";

 

 getchar();getchar();

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика