Напишите программу на C ++, чтобы найти третий угол треугольника. Введите 1-й угол треугольника: 30
Введите 2-й угол треугольника: 60​

вёдра вёдра    3   14.03.2021 11:10    3

Ответы
царапина123 царапина123  14.03.2021 11:20

#include<iostream>

#include<iomanip>

#define _USE_MATH_DEFINES

#include<cmath>

using namespace std;

 

int main()

{

   double a, b, c, alfa, beta, gamma;

   

   cout <<"a="; cin >> a;

   cout <<"b="; cin >> b;

   cout <<"c="; cin >> c;

   

   if (a+b>c && a+c>b && b+c>a)

   {    

   alfa = acos((b*b+c*c-a*a)/(2*b*c))*180/M_PI;

   beta = acos((a*a+c*c-b*b)/(2*a*c))*180/M_PI;

   gamma = acos((a*a+b*b-c*c)/(2*a*b))*180/M_PI;    

   cout <<"Angles in degrees:\n";

   cout <<setprecision(3)<<fixed<< "alfa=" << alfa << " beta=" << beta << " gamma=" << gamma << endl;

   }

   else cout << "Triangle absent\n";

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика