Напишите программу, которая запрашивает числа. Программа должна остановиться запрашивать, когда мы вводим 0. Программа должна вывести количество введенных чисел и среднее значение. питон

2зик20 2зик20    2   22.02.2021 19:49    57

Ответы
afspafa afspafa  24.03.2021 19:50

N = int(input())

s = 0

k = 0

sr = 0

while N != 0:

   s += N

   k += 1

   N = int(input())

sr = s/k

print('Количество введённых чисел - ',k)

print('Среднее арифметическое введённых чисел = ',sr)


Напишите программу, которая запрашивает числа. Программа должна остановиться запрашивать, когда мы в
ПОКАЗАТЬ ОТВЕТЫ
ddurua ddurua  24.03.2021 19:50

//Python 3.8.3

from typing import Callable, Any, Iterable

import statistics

def ReadSeqIntWhile(predicate: Callable[[Any], bool]) -> Iterable[Any]:

   temp = int(input())

   while(predicate(temp)):

       yield temp  

       temp = int(input())

def main():

   sequence = list(ReadSeqIntWhile(lambda p: p != 0))

   print(f"numbers count: {len(sequence)}, average value: {statistics.mean(sequence)}")

if __name__ == "__main__":

   main()

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика