Напишите программу, которая заменяет расширение у заданного имени файла. входные данные первая строка содержит имя файла, которое нужно изменить. во второй строке записано нужное расширение. выходные данные программа должна вывести изменённое имя файла с заданным расширением. примеры входные данные qwerty exe выходные данные qwerty.exe входные данные qwetry.old.pas html выходные данные qwetry.old.html

dimar3256 dimar3256    2   28.07.2019 13:40    51

Ответы
//Pascal ABC.NET v3.1 сборка 1219

Var
 s,sf:string;
begin
 readln(s);
 readln(sf);
 if pos('.',s)<>0 then
 delete(s,s.LastIndexOf('.')+2,length(s)-s.LastIndexOf('.'))
 else
 s+='.'; 
 writeln(concat(s,sf));
end.

Пример ввода:
point.simple.txt
pdf
Пример вывода:
point.simple.pdf
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика