Напишите программу, которая выводит в порядке возрастания все корни уравнения ax3+bx2+cx+d=0 на отрезке [0,1000]. Если решений к данному уравнению не существует, то ничего выводить не нужно. Вводные данные: на четырех строках даны числа коэффициенты уравнения A, B, C и D.
Исходные данные: на разных строках вывести все корни уравнения, если таковые существуют.
Пример 1
Ввод:
1
-6
8
0

Вывод:
0
2
4

Sayn1 Sayn1    2   08.04.2021 10:30    9

Ответы
Apelsin2403 Apelsin2403  08.05.2021 10:31

Если все коэффициенты и корни целые, то так:

a = int(input('a: '))

b = int(input('b: '))

c = int(input('c: '))

d = int(input('d: '))

   

for x in range(0, 1001):

   if a*x**3 + b*x**2 + c*x + d == 0:

       print('Корень: ' + str(x))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика