Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.

Входные данные
Входная строка содержит произвольную последовательность символов.

Выходные данные
Программа должна вывести последнее слово этой строки.
на c++

lnk88 lnk88    3   12.04.2020 18:30    22

Ответы
doc2934 doc2934  13.10.2020 03:04

#include <iostream>

#include <string>

#include <Windows.h>

int main()

{

   // Русский язык в консоли

   SetConsoleCP(1251);

   SetConsoleOutputCP(1251);

   std::string s;

   std::cout << "Введите строку: ";

   std::getline(std::cin, s);

   std::cout << "Последнее слово строки: " << s.substr(s.find_last_of(' ')+1);

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика