Напишите программу, которая выводит первое слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки. Решение с комментариями к каждой строке кода. Комментарии должны пояснять, что происходит в каждой строке программы, для чего она нужна и т.п.

Входные данные
Входная строка содержит произвольную последовательность символов.

Выходные данные
Программа должна вывести первое слово этой строки.

Примеры
входные данные
Vasya is a pupil.
выходные данные
Vasya

Miky14 Miky14    3   21.04.2020 12:49    13

Ответы
abdulismailova2 abdulismailova2  13.10.2020 14:11

program z1;// название программы

var s:string;// описание переменной s (строки)

begin//начало блока программы

read(s);//ввод данных (строки)

if pos(' ',s)<>0 then //оператор выбора определяющий из одного слова строка или нет, если pos равно 0, то слово одно

write (copy(s,1,Pos(' ',s)-1))//если нет то вывод копии строки с 1 символа по позицию пробела минус 1 символ

else write (s)//если да то вывод просто заданной строки

end.//конец блока программы

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика