Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры.

lexelol2005 lexelol2005    3   16.08.2019 00:40    8

Ответы
Velichkovskaya0 Velichkovskaya0  04.10.2020 22:01
Var
i, j, n : integer;
flag : boolean;
begin
write('n = ');
read(n);
for i := 2 to n do begin
flag := true;
for j := 2 to i-1 do
if (i mod j = 0) then begin
flag:=false;
break;
end;
if flag = true then write(i, ' ');
end;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика