Напишите программу, которая выводит на экран последний член последовательности 1, -3, -7, -11, - меньший заданного числа и его сумму с предыдущими членами последовательности

dyganovanton dyganovanton    2   01.09.2019 22:10    3

Ответы
Yourmom228black Yourmom228black  06.10.2020 10:33
Program hhh54;
var n,x,s:longint;
begin
  s:=0;
  read (n);
  x:=1;
  while x > n do
    begin
      s:=s+x;
      x:=x-4;
    end;
  s:=s+x;
  write (x,' ',s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика