Напишите программу, которая выведет номера всех лунок в гольфе, в которые нужно попасть, чтобы выиграть битву. Определяется это так. Нужно найти самую короткую из двух введенных строк, ее длина даст нам начальное число. Тогда длина оставшейся строки даст конечное число. А шаг – это число, введенное последним. Формат ввода
Вводятся две строки и число.

Формат вывода
Вывести все числа в диапазоне от длины короткой строки до длины длинной строки (не включая) с шагом, равным числу.

Пример 1
Ввод Вывод
Bilbo will do without a real bed and Breakfast.
Bilbo, you're a fool, you've got yourself into this business of your own free will.
3 47 50 53 56 59 62 65 68 71 74 77 80

ElenaDzaraxova ElenaDzaraxova    3   27.11.2021 10:24    9

Ответы
gilmutdinova011 gilmutdinova011  27.11.2021 10:30

start = input('Введите первую строку: ')

stop = input('Введите вторую строку: ')

num = int(input('Введите число: '))

if len(start) > len(stop):

   start, stop = stop, start

for i in range(len(start), len(stop), num):

   print(i)

Объяснение:

На Python

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика