Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером k и заканчивая элементом с номером m(включительно).

rrrrrrrrtttttttttyyy rrrrrrrrtttttttttyyy    2   08.06.2019 01:10    6

Ответы
Ksushhha00 Ksushhha00  07.07.2020 13:14
Var
  i,k,m,j:integer;
  a,b:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(50);
  write(a[i]:3);
  end;
writeln;
write('Введите k и m: ');
readln(k,m);
j:=m;
for i:=k to m do
  begin
  b[j]:=a[i];
  j:=j-1;
  end;
for i:=k to m do  a[i]:=b[i];
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i]:3);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика