Напишите программу которая выделяе в другой массив все элементы исходного массива,которые встречаются более одного раза,с++,не писать свой код,а изменить мой, учтите что тесты могут быть 5
1 1 1 1 1
И тогда программа должна вывести лишь одну единицу
5
1 2 2 1 3
Вывод
1 2


Напишите программу которая выделяе в другой массив все элементы исходного массива,которые встречаютс

пвиопп пвиопп    1   21.01.2022 08:40    4

Ответы
VasilisaLisMUR VasilisaLisMUR  21.01.2022 08:40

ответ в прикрепленном файле.

ПОКАЗАТЬ ОТВЕТЫ
Milena20171 Milena20171  21.01.2022 08:40

Резюмирую:

1) Использование того, чего не понимаешь (6-8 строки)

2) Решение за O(N^2) при ограничении N < 10^5, что очень плохо

3) Нет проверки на выход за границы выделенной памяти (20, 22 строки)

4) Абсолютно неверная идея алгоритма: сравнивать только соседние элементы, да и еще и непонятно зачем делать во вложенном цикле + неверное написание тела цикла фор: полное непонимание того, как он работает и что делает

5) Нет проверки на то, использовали мы конкретное число уже или нет

Итог: полностью неверное решение, которое надо не менять, а стирать и переделывать.

Возможное решение на сотку:

#include <iostream>

#include <vector>

#include <map>

using namespace std;

signed main() {

   map<int, int> cnt;

   int n;

   cin >> n;

   vector<int> a(n), res;

   for(auto &i: a){

       cin >> i;

       cnt[i]++;

   }

   for(auto &i: a){

       if(cnt[i] > 1) res.push_back(i);

       cnt[i] = 0;

   }

   if(res.empty()) cout << 0;

   else for(auto &i: res) cout << i << " ";

}

P.S. Если что непонятно, то спрашивай - распишу поминутно кто где того самого

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика