Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до 10 в программе Phyton

120505567890 120505567890    2   07.02.2022 01:02    5

Ответы
kira315 kira315  07.02.2022 01:10

k = 0

for n in range(0,11,2):

   k += n

print(k)

ПОКАЗАТЬ ОТВЕТЫ
Dzhemre69 Dzhemre69  07.02.2022 01:10

Первый :

s = 0

for k in range(1,11):

   if k % 2 ==0:

       s += k

print(s)

Второй :

s = 0

for k in range(1,11):

   s += k*((k+1)%2)

print(s)

Третий :

print(sum([ k*((k+1)%2) for k in range(1,11)]))

*Четвертый :

print(sum([ k for k in range(0,11, 2)])) - подсказал второй ответ.

**Оказывается есть пятый, самый легкий :

print(sum(range(0,11,2)))  

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика