Напишите программу, которая вычисляет сумму, среднее арифметическое и произведение первых 20 чисел. . буду !

justlikekatya justlikekatya    2   24.09.2019 14:40    2

Ответы
hhhh34 hhhh34  01.05.2020 21:43
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var s:=1.To(20);
  Writeln('Сумма ',s.Sum,', среднее арифметическое ',s.Average,
      ', произведение ',s.Aggregate(BigInteger(1),(p,q)->p*q))
end.

Результат
Сумма 210, среднее арифметическое 10.5, произведение 2432902008176640000
ПОКАЗАТЬ ОТВЕТЫ
nastyakostikov1 nastyakostikov1  01.05.2020 21:43
Program srednee_chisel;uses crt;var q,x,s:longint; a:real;begin clrscr;q:=1;for x:=1 to 20 do begins:=s+x;q:=q*x; end;a:=s/20;writeln ('Сумма', s:5);writeln ('Среднее арифметическое', a:5);writeln ('Произведение', q:6);readln; end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика