Напишите программу, которая вычисляет среднюю за неделю температуру воздуха. исходные данные вводятся с клавиатуры. пример входных данных. понедельник> > 12 вторник> > 10 среда> > 16 четверг> > 18 пятница> > 17 суббота> > 16 воскресенье> > 14 пример выходных данных средняя температура за неделю: 14.71

dmitrocreativ dmitrocreativ    1   04.10.2019 19:20    28

Ответы
veratokareva31 veratokareva31  17.08.2020 08:06

var


 sum, temp, i: integer;


 sr: real;


 d_n: array[1..7] of string;


 


begin


 sum := 0;


 d_n[1] := 'Понедельник>>'; d_n[2] := 'Вторник>>'; d_n[3] := 'Среда>>'; d_n[4] := 'Четверг>>'; d_n[5] := 'Пятница>>'; d_n[6] := 'Суббота>>'; d_n[7] := 'Воскресенье>>';


 for i := 1 to 7 do


 begin


   write(d_n[i]);


   readln(temp);


   sum += temp;


 end;


 writeln(sum / 7);


end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика