Напишите программу, которая вычисляет факториал натурального числа n ( 1 ≤ n ≤ 10000 ), сохранив все значащие цифры. факториалом называется произведение всех натуральных чисел от 1 до n : n ! = 1·2· ( n - 1)· n . входные данные входная строка содержит натуральное число n ( 1 ≤ n ≤ 10000 ). выходные данные программа должна вывести факториал числа n . примеры входные данные 6 выходные данные 720 pascal abc 1.8

Дарья02031 Дарья02031    2   22.08.2019 17:20    4

Ответы
maryrous maryrous  05.10.2020 13:04
//PascalABC.NET 3.2, старой версии нет, не могу проверить

begin
  var a: BigInteger := 1;
  for var i := 1 to ReadInteger do
    a *= i;
  write(a)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика