Напишите программу, которая выбирает максимальное и минимальное из трёх введённых чисел. pascal

dover2 dover2    3   02.07.2019 22:00    5

Ответы
indira227 indira227  02.10.2020 18:45
Var
a,b,c,max,min:integer;
Begin
Readln(a,b,c);
if (a>b) and (a>c) then max:=a;
if (b>a) and (b>c) then max:=b;
if (c>a) and (c>b) then max:=c;
if (a<b) and (a<c) then min:=a;
if (b<a) and (b<c) then min:=b;
if (c<a) and (c<b) then min:=c;
Writeln('Максимальное значение - ', max, 'Минимальное - ', min);
end.
ПОКАЗАТЬ ОТВЕТЫ
diana0483 diana0483  02.10.2020 18:45
PascalABC.Net

program MyProg;

var
  max_a, max1, min_a, min1, a, b, c: longint;

begin
  writeln('Введите три числа');
  readln(a, b, c);
  min1 := min(a, b);
  min_a := min(min1, c);
  max1 := max(a, b);
  max_a := max(max1, c);
  writeln('Максимальное число ', max_a);
  writeln('Минимальное число ', min_a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика