Напишите программу, которая вводит трехзначное число и находит сумму цифр этого числа.

ЖеньОК282 ЖеньОК282    1   16.05.2019 16:14    2

Ответы
Ghostremel Ghostremel  10.06.2020 12:35

var

a,b,c,n,s: integer;

begin

readln(n);

if ((n>99) and (n<1000)) then

begin

a:=n div 100;

b:=n div 10 mod 10;

c:=n mod 10;

s:=a+b+c;

writeln('Сумма трех цифр равна ',s);

end else writeln('Введите трехзначное число!');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика