Напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ с конца строки до тех пор, пока в строке не останется 1 символ. входные данные: ввести строку с длиной не более 255 символов. выходные данные: вывести строку, сокращая каждый раз на 1 символ (в начале вывести всю строку, последней строкой должна быть строка из одного символа) с конца строки до тех пор, пока в строке не останется 1 символ. в паскаль. и если не трудно с объяснением. заранее огромнейшее !

Kpuc2100 Kpuc2100    2   20.07.2019 01:50    5

Ответы
Маргоht Маргоht  22.09.2020 18:45
Я не знаю, что тут нужно пояснять. первый оператор вводит строку, второй выводит в цикле...

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var s:=ReadlnString('Исходная строка:');
  for var i:=s.Length downto 1 do Writeln(Copy(s,1,i))
end.

Тестовое решение:
Исходная строка: Дронопотам
Дронопотам
Дронопота
Дронопот
Дронопо
Дроноп
Дроно
Дрон
Дро
Др
Д
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика