Напишите программу, которая вводит с клавиатуры 15 реальных чисел, организовывает их хранение в массиве и определяет разность между максимальным и минимальным элементом массива.

basovaolga67 basovaolga67    1   25.07.2019 06:50    1

Ответы
keep19995 keep19995  24.09.2020 11:17
Const n=15;
var x:array[1..15] of real;
i:integer; max,min:real;
begin
for i:=1 to n do
 begin
 write('x[',i,']=');
 readln(x[i]);
 end;
max:=x[1]; min:=x[1];
for i:=2 to n do
 begin
  if x[i]>max then max:=x[i];
  if x[i]<min then min:=x[i];
 end;
writeln('max-min = ',max,' - ',min,' = ',max-min);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика