Напишите программу, которая вводит номер месяца и выводит название времени года на языке. при вводе неверного номера месяца должно быть выведено слово 'no'.

Тучка12 Тучка12    1   05.07.2019 13:40    2

Ответы
Devyshkaleto2017 Devyshkaleto2017  28.07.2020 23:47
// здесь кусок кода, в котором считываем введённый месяц в переменную
//month
char getTime(int month)
switch (month){
case '1' : return 'winter'; break;
case '2' : return 'winter'; break;
case '12' : return 'winter'; break;
case '3' : return 'spring'; break;
case '4' : return 'spring'; break;
case '5' : return 'spring'; break;
case '6' : return 'summer'; break;
case '7' : return 'summer'; break;
case '8' : return 'summer'; break;
case '9' : return 'autumn'; break;
case '10' : return 'autumn'; break;
case '11' : return 'autumn'; break;
default : 'NO'; break;
}
printf(getTime(month));
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика