Напишите программу, которая вводит натуральное число n и определяет его факториал. мне нужна программа на языке с++

89195188243aMils 89195188243aMils    2   11.09.2019 02:20    2

Ответы
Хулиганочка13 Хулиганочка13  07.10.2020 06:35
Оформил через рекурсивную подпрограмму

#include <bits/stdc++.h>

using namespace std;

int Factor(int n)
{
    if (n == 1)
        return 1;
    return Factor(n-1)*n;
}
int main()
{
    int N;
    cin >> N;
    cout << Factor(N);
}

Аналог:

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int N;
    cin >> N;
    int ans = 1;
    for (int i = 1; i <= N; ++i)
        ans *= i;
    cout << ans;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика