Напишите программу, которая вводит натуральное число N и находит сумму всех натуральных чисел от 1 до N .

Входные данные
Входная строка содержит единственное целое число N .

Выходные данные
Программа должна вывести сумму натуральных чисел от 1 до введённого числа N .

Примеры
входные данные
100
выходные данные
5050

dashoostik dashoostik    2   27.02.2020 14:43    24

Ответы
baller59 baller59  05.08.2020 16:22

Вот,программа на языке Pascal

program summa;

var n,a,c: integer;

begin

readln(n);

a:=0;

c:=1;

repeat

a:=a+c;

inc(c);

until c>n;

writeln(a);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика