Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными (паскаль авс)

привет897 привет897    2   03.07.2019 17:10    7

Ответы
mamba211004 mamba211004  27.07.2020 16:26
UPD

Var
a,b,s,i:integer;
begin
readln(a,b);
if a <> b then
for i:=1 to abs(b) do s:=s+a
else for I:=1 to abs(b) do s:=s+a;
if (a<0) and (b<0) then s:=abs(s)
else if b<0 then s:=-s;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Lenaaaa111 Lenaaaa111  27.07.2020 16:26
Var A,B,i,S:integer;
Ch:Char;
Begin
S:=0;
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
if ((A<0)and(B>0))or((A>0)and(B<0)) then Ch:='-';
A:=Abs(A);
B:=Abs(B);
For i:= 1 to A do
 S:=S+B;
WriteLn(Ch,S)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика