Напишите программу которая вводит четырехзначное число и определяет верно ли что его десятичной записи цифры стоят в порядке возрастания

Sokolova2327 Sokolova2327    2   12.04.2019 19:35    77

Ответы
Тэхен10 Тэхен10  29.05.2020 09:18

пишем имя программы

Program:chetre;

вводим переменные. для ввода переменных в программе используется тег <var> , который нужен для выделения переменных компьютерных программ

Var

n,i:

после ввода переменных ставим двоеточие и вводим тип данных ,в данном случае это целое или на языке паскаль integer

Var

n,i: integer;

теперь пишем начало

Begin

введём переменную n

Write('n = ');Read(n);

теперь присваиваем  значение переменной i

i:=0;

дальше вы наверное всё поймёте

if n div 1000 = n mod 10 then i:=i+1;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if i=1 then Write('Верно')

else Write('Не верно')

End.

вот полная программа без всяких вставок

Рrogram:chetre;

Var

n,i:integer;

Begin

Write('n = ');Read(n);

i:=0;

if n div 1000 = n mod 10 then i:=i+1;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if (n mod 10 = (n div 10) mod 10) then i:=i+1;

n:=n div 10;

if i=1 then Write('Верно')

else Write('Не верно')

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика