Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла , а вывод – (в скобках указана размерность массива) 1. подсчитать произведение неотрицательных элементов в двухмерном массиве 6 × 3;

Sveta1314 Sveta1314    3   17.08.2019 14:10    5

Ответы
Alexa20 Alexa20  05.10.2020 00:52
Program z1;
var
i, j, p: integer;
a: array[1..6, 1..3] of integer;
begin
p := 1;
i := 1;
j := 1;
while i <= 6 do
begin
    while j <= 3 do
    begin
        write('a[',i,'][',j,']=');
        readln(a[i,j]);
        j := j + 1;
    end;
    i := i + 1;
end;
i := 1;
j := 1;
repeat
    repeat
        if a[i,j] >= 0 then
           p := p * a[i,j];
        j := j + 1;
    until j > 3;
    i := i + 1;
until i > 6;
writeln('произведение неотрицательных элементов: ',p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика