Напишите программу, которая возводит в квадрат трехзначное число, введённое с клавиатуры, при условии, что в числе содержится цифра 7. если в числе нет цифры 7, то следует вывести число в исходном виде(через оператор if)паскаль

МаксимНелучший МаксимНелучший    3   25.08.2019 15:40    2

Ответы
run5555 run5555  02.08.2020 23:57
Var a:integer; s:string;
begin
 readln(a);
 str(a,s);
 if (pos('7',s)>0)
 then
   a:=a*a;
 writeln(a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика