Напишите программу которая в зависимости от введенной оценки в диапазоне от 1 до 12 выводит уровень к которому она относится c++​

akm0910 akm0910    3   05.10.2019 17:34    3

Ответы
Serator2006 Serator2006  09.10.2020 22:07

#include <iostream>

using namespace std;

int main() {

int n;

cin>>n;

switch (n)

{

case 1:

case 2:

case 3:

 cout<<"Неудовлетворительно";

 break;

case 4:

case 5:

case 6:

 cout<<"Удовлетворительно";

 break;

case 7:

case 8:

case 9:

 cout<<"Хорошо";

 break;

case 10:

case 11:

case 12:

 cout<<"Отлично";

 break;

default: cout<<"Ошибка ввода";

}

return 0;

}

Вот сам макет программы. Если нужны дугие уровни оценок - можно просто заменить выводимый текст на требуемый.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика