Напишите программу, которая в последовательности n натуральных чисел определяет максимальное число, кратное 4. программа получает на вход n-ное количество чисел. в последовательности всегда имеется число, кратное 4. программа должна вывести одно число — максимальное число, кратное 4.

valkiriyali valkiriyali    1   04.06.2019 21:30    5

Ответы
odyvanchik22 odyvanchik22  05.07.2020 16:49
var
  i, n, k, max: integer;

begin
  readln(n);
  max := Integer.MinValue;
  for i := 1 to n do
  begin
    readln(k);
    if (k mod 4 = 0) then
      max := System.Math.Max(max, k);
  end;
  writeln(max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика