Напишите программу, которая суммирует все числа в диапазоне от 4 до 32 и вычисляет их среднее арифметическое, выводит эти числа на экран в строчку и на отдельных строках выводит сумму и среднее арифметическое

ОЧЕНЬ ВАЖНО! ДАМ ВЫСШУЮ НАГРАДУ

McEgorKa McEgorKa    1   09.04.2020 17:46    4

Ответы
sarah205682 sarah205682  13.10.2020 00:27

var  

 S,SA:real;

 i,k:integer;

begin

 S:=0;

 

 SA:=0;

 

 for i:=4 to 32 do

 begin

  S:=S+i;

  k:=k+1;

 end;

 SA:=S/k;

 

 write('Sum = ',S,'   Arithmetic mean = ',SA);

end.  

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика