Напишите программу, которая спрашивала бы сокращенное имя, а печатала полное для пяти ваших друзей. ввод незнакомого имени должен провоцировать заявление типа «я с вами незнакома

152003152003 152003152003    2   30.07.2019 20:10    7

Ответы
Дамирка2288 Дамирка2288  07.09.2020 23:19
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var names:array[1..2,1..5] of string:=
    (('Саша','Женя','Таня','Лена','Вася'),
    ('Александр','Евгений','Татьяна','Елена','Василий'));
  var name:=ReadlnString('Введите краткое имя:');
  var p:=0;
  for var i:=1 to 5 do
    if name=names[1,i] then begin p:=i; break end;
  if p>0 then Writeln(names[2,p])
  else Writeln('Я вас не знаю!')
end.

Тестовое решение
Введите краткое имя: Лена
Елена
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика