Напишите программу, которая сортирует одномерный массив. дана матрица размерами 4 на 4. заполните ее следующим образом: если сумма индексов четная – в ячейке должно содержаться произведение индексов, если сумма индексов нечетная – в ячейке должна содержаться сумма индексов. постройте график параметрической функции , если x(t) = cos(t2), y(t) = sin(t2). в стране цифра есть 9 городов с названиями 1, 2, 3, 4, 5, 6, 7, 8, 9. путешественник обнаружил, что два города соединены авиалинией в том и только в том случае, если двузначное число, составленное из цифр-названий этих городов, делится на 3. можно ли добраться из города 1 в город 9? в городе маленьком 15 телефонов. можно ли их соединить так, чтобы было 4 телефона, каждый из которых соединен с тремя другими, 8 телефонов, каждый из которых соединен с шестью, и 3 телефона, каждый из которых соединен с пятью другими?

nik863 nik863    2   20.09.2019 07:00    5

Ответы
pdgjdis pdgjdis  08.10.2020 04:04
№1

#include <iostream>
using namespace std;
int main() {
int *arr; int size;
cout << "n = ";
cin >> size;
if (size <= 0) {
 cerr << "Invalid size" << endl; return 1;
}
arr = new int[size]; 
for (int i = 0; i < size; i++) {
 cout << "arr[" << i << "] = "; cin >> arr[i];
}
int temp;
for (int i = 0; i < size - 1; i++) {
 for (int j = 0; j < size - i - 1; j++) {
  if (arr[j] > arr[j + 1]) {
   temp = arr[j]; arr[j] = arr[j + 1]; arr[j + 1] = temp;
  }
 }
}
for (int i = 0; i < size; i++) {
  cout << arr[i] << " ";
}
cout << endl;
delete[] arr;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика