Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. исходное число не превышает 30 000. программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. если число состоит из одной цифры, то минимальным является значение самой этой цифры. примеры работы программы: ввод: 3; вывод: 3 ввод: 2194; вывод: 2

yuliaovcharova yuliaovcharova    1   19.06.2019 16:30    4

Ответы
Sladkayaaaaaa Sladkayaaaaaa  15.07.2020 20:55
Var a,af,al:integer;
begin
  writeln('Введите число');
  readln(a);
  if a<10 then writeln('ответ: ',a)
  else
  if a<=99 then
  begin
  af:=a div 10;
  al:=a mod 10;
  if af>al then writeln('ответ: ',al) else writeln('ответ: ',af)
  end
  else
  if a<=999 then
  begin
  af:=a div 100;
  al:=a mod 10;
  if af>al then writeln('ответ: ',al) else writeln('ответ: ',af)
  end
  else
  if a<=9999 then
  begin
  af:=a div 1000;
  al:=a mod 10;
  if af>al then writeln('ответ: ',al) else writeln('ответ: ',af)
  end
  else
  if a<=30000 then
  begin
  af:=a div 10000;
  al:=a mod 10;
  if af>al then writeln('ответ: ',al) else writeln('ответ: ',af)
  end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика