Напишите программу, которая считывает с клавиатуры строку s и определяет, встречаются ли в строке s слова палиндромы. словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя. строка s не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов

anton2015b anton2015b    3   05.06.2019 23:00    1

Ответы
motorindmitry12 motorindmitry12  01.10.2020 20:09
Var
 s,t:string;
 n,i:integer;
begin
write('Введите строку: ');
readln(t);
n:=1;
t:=t+' ';
for i:=2 to length(t) do
  if ((t[i]=' ') or (i=length(t)))  and (i-n>1) then
    begin
    s:=Copy(t,n,i-n);
    if s=ReverseString(s) then
      begin
      writeln('Да, палиндромы есть');
      halt
      end
        else n:=i+1
    end;
writeln('Палиндромов нет')    
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика