Напишите программу, которая считывает с клавиатуры n чисел и затем выводит на экран сумму и среднее арифметическое отрицательных чисел. в паскаль

gerl1999 gerl1999    1   08.08.2019 07:20    3

Ответы
sirkovake sirkovake  04.10.2020 04:33
Var i,n,nmb: integer;
    dg,sm: real;
begin
  sm:=0;  nmb:=0;
  write('n = ');
  readln(n);
  write('числа через пробел: ');
  for i:=1 to n do
  begin
    read(dg);
    if dg<0 then
    begin
      sm:=sm+dg;
      nmb:=nmb+1;
    end;  
  end;
  writeln('сумма отрицательных чисел = ',sm);
  writeln('среднее арифметическое = ',sm/nmb);
end.    
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика