Напишите программу, которая считывает с клавиатуры два целых числа и строку.Если эта строка является обозначением одной из четырѐх математических операций (+, -, *,/), то выведите результат применения этой операции к введѐнным ранее числам, в противном случае выведите «Неверная операция». Если пользователь захочет поделить на ноль, выведите текст«На ноль делить нельзя!».На вход программе подаются два целых числа, каждое на отдельной строке, и строка.Программа должна вывести результат применения операции к введенным числам или соответствующий текст, если операция невернаялибо если происходит деление на ноль.

Котенок050402 Котенок050402    3   16.03.2021 18:47    37

Ответы
lenok140 lenok140  15.04.2021 18:48

Python:

while True:

 try:

   a = int(input('Введите a: '))

   break

 except ValueError:

   print('Вводите целое число!')

while True:

 try:

   b = int(input('Введите b: '))

   break

 except ValueError:

   print('Вводите целое число!')

c = input('Введите действие (+,-,*,/): ')

if c == '+': print(a+b)

elif c == '-': print(a-b)

elif c == '*': print(a*b)

elif c == '/':

 if b != 0: print(a/b)

 else: print('На ноль делить нельзя')

else: print('Неверная операция')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика