Напишите программу, которая считывает произвольное количество чисел до стоп-слова "stop" и выводит, сколько раз среди них встречается первое введенное число (включая первое вхождение). sample input: 8 1 6 1 6 10 8 10 1 2 9 4 2 6 3 4 9 3 1 6 10 8 4 9 10 2 3 1 stop sample output: 3

asaparova80 asaparova80    2   23.09.2019 11:01    13

Ответы
френки9 френки9  08.10.2020 12:11
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var s1:=ReadlnString;
  if s1='STOP' then Writeln(0)
  else begin
    var k:=1;
    ReadSeqStringWhile(t->t<>'STOP').ForEach(w->if w=s1 then k+=1);
    Writeln(k)
    end
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика