Напишите программу, которая считывает натуральное число n и выводит на экран случайное натуральное число, меньшее n и оканчивающееся на 1. Гарантируется, что будет ввeдено натуральное число 1

dovlarisa dovlarisa    1   08.05.2020 20:16    1

Ответы
2017mariana 2017mariana  14.10.2020 12:06

Программа:

program MrSolution;

var n: integer;

function MrSolutionRandom(topBorder: integer):integer;

var rand: integer;

begin

 randomize;

 rand:= random(0, topBorder-1);

 MrSolutionRandom:= rand-rand mod 10+1;

end;

begin

  write('Введите натуральное число, кроме 1 >> ');

  repeat

    readln(n);

  until n<>1;

  writeln(MrSolutionRandom(n));

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика