Напишите программу, которая считает количество предложений во введенной строке и выводит его. предложение может заканчиваться на: . (точка) ; (точка с запятой) ? (вопросительный знак)

lizavetabelkin lizavetabelkin    3   23.09.2019 11:01    5

Ответы
Thanks2y Thanks2y  08.10.2020 12:09
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (s,k):=(ReadlnString,0);
  for var i:=1 to s.Length do
    if s[i] in ['.',';','?'] then k+=1;
  Writeln('Количество предложений равно ',k)  
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика