Напишите программу, которая считает количество чётных цифр введённого числа. ---Входные данные---
Входная строка содержит одно натуральной число N .

---Выходные данные---
Программа должна вывести количество чётных цифр введённого числа.
ПРИМЕР
Ввод
123456
Вывод
3
Ввод
13579
Вывод
0
Желательно на Питоне или Паскале с использованием РЕКУРСИИ(фунции или процедуры)!

danilkalmykov1 danilkalmykov1    1   08.12.2020 03:59    42

Ответы
vityastah vityastah  07.01.2021 03:59

#include <iostream>  

using namespace std;

int main()

{

   long long a, sum = 0;

   cin >> a;

   while(a)

   {

       if((a%10) % 2)

           sum++;

       a/=10;

   }

   cout << sum << endl;

   return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика