Напишите программу, которая принимает два вещественных числа, значение для числа десятичных знаков, вычисляет сумму и выводит результат. попробуйте ввести действительное число для числа знаков после запятой.

polo73oye61z polo73oye61z    1   01.10.2019 09:15    3

Ответы
милаха80 милаха80  09.10.2020 07:29

program Real2;

var

 a, b, d: Real;

 id: Integer;

begin

 Write ('Введите два вещественных числа: ');

 Read (a, b);

 Write ('Введите число знаков после запятой: ');

 Read (d);

 id := Trunc (d);

 WriteLn;

 Write ('Сумма = ', a + b :15 :id);

 ReadLn;

 ReadLn;

end.

Объяснение:

действительное число для количества знаков после запятой вводится в d, затем чтобы использовать его в форматировании вывода преобразуется в целое (id := Trunc (d); ).

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика